TASK [common : Set system hostname] fatal

I installed 2.4.2. Ran yum update. Then ran rock tui and configured each line item. Wrote to config file. During deployment I get this error with anything i have tried…

    `fatal : [ansible_host=]: FAILED! => {"changed": false, "msg": "Command failed rc=1, out=, err=Could not set property: Invalid hostname 'ansible_host='\n"}`

In TUI I have tried setting hostname to myhostname and myhostname.domain. I have used set-hostname to both myhostname and myhostname.domain. In /etc/rocknsm/hosts.ini I have changed to both myhostname and myhostname.domain.
I have also tried in TUI to set management interface to both static and dhcp. I have also tried both online an offline installers.

Need some assistance.

Figured it out. In hosts.ini I was doing [ansible_host=myhost]. Changed it to just [myhost] and it worked.

My actual problem was the hostname was missing

#ansible_host= ansible_connection=local
ansible_host=localhost ansible_connection=local

#ansible_host= ansible_connection=local
somehost_name ansible_host=localhost ansible_connection=local