Packages not found

elasticsearch, kibana , kafka , bro, stenographer … not found help please

please read the documenation first, you are supposed to run ‘sudo rock setup’ and choose what to install

https://docs.rocknsm.io/install/install/

based on your prior repeat questions i’m almost certain you are out of your depth here, are you certain rocknsm is what you need ?

Hey Rami

When installing a new RockNSM i found what i believe is the cause for your request.

When you upgrade the rocknsm OS before running ‘sudo rock setup’ it breaks the installation process.
I found update is okay but upgrade is not.

sudo yum update
sudo yum install kibana

to be required for the deployment process to work well.
now run

sudo rock setup

i didnt do the upgrade
when I run sudo rock setup i cant select nothing to install then it is not found when I run sudo rock status

also the command yum is not found

you must be joking

know the only supported way is to use the RockNSM iso to install
have you ever installed an operating system ?

no its the first time that i use the virtualbox

i don’t think this product is what you expect it to be, neither is it suitable for starters

what are you trying to learn or achieve ?

i am going to get my master diploma with this project that’s why i need all instructions to install and begin

? I’m afraid if you fail to create a VM with virtuabox and install RockNSM from the iso you’re in for a hard time

Did you create the administrative user during installation ? Did you flag the ‘administrative user flag’ ? Did you click on advanced and validate the user is part of the wheel group ?

Pretty much everything needed to get an installation of RockNSM up in a VM or bare metal is here:

https://docs.rocknsm.io/

There is even a VM Build guide with instructions here:

https://docs.rocknsm.io/install/vm_installation/

That being said the documentation does not cover exhaustive prerequisites like installing VirtualBox or VMWare. In your learning if you see something that is foreign to you I would recommend looking it up and doing some additional research to understand what it is and then how it relates to RockNSM. There are a lot of moving parts and software changes at a rapid pace.

what’s the solution for this error : sudo rock start

Check this thread Elasticsearch Service Fails to Start - #4 by Thibs

like i said, please do read comments and take note

you need to adjust the installation for it to work