Getting Rock on RHEL


#22

Still working the issue, I will hopefully have more information this week.


#23

Update: I was able to get it to generate the config.yml now. The issues i’m having now is when I try to deploy_rock.sh. Attached is a screenshot

I am able to ping 8.8.8.8 and my interface has an IP. Do you have any suggestions?


#24

Were there any changes made to the installation `etc/rocknsm/config.yml file?


#25

Try deleting the second line in /usr/share/rock/playbooks/site.yml
should be the line that says “- import_playbook: generate-defaults.yml”

then after that you need to modify the /etc/rocknsm/config.yml
2 changes,
“rock_online_install: True”
“rock_disable_offline_repo: True”

after you set both of those settings try deploying.


#26

@koelslaw no changes where made

@spartan782 I will try this in just a minute


#27

@spartan782 Same Error no changes


#28

Ah, my bad forgot that the damage was already done. Need to delete

/etc/yum.repos.d/rocknsm-local.repo

then try the deploy.


#29

That doesn’t even exist yet @spartan782

only file in my /etc/yum.repos.d/ is redhat.repo


#30

@spartan782 deploy creates the `RockNSM-local.repo no matter what the config is saying

@Nick sudo mkdir -p /srv/rocknsm/support


#31

@koelslaw thats why I had him delete line 2 in site.yml.

Turns out you have discovered a bug. The ansible script doesn’t create the directory as @koelslaw has already beaten me to the bandaid.


#32

That worked… kinda… new error


#33

It is because RHEL appears to be inserting “7Server” when it should just be "base/7/x86_64. Haven’t run into this before but maybe try this and see what happens?

Gonna have to manually edit a file in /etc/yum.repos.d/
Centos-Base.repo

where it says release=$releasever change it to release=7
example
mirrorlist=http://mirrorlist.centos.org/?release=7&arch=$basearch&repo=os

EDIT:
Should note you will need to change each time that appears


#34

I edited that file and ran deploy_rock.sh. When I run the script it reverts it back to before I made the change


#35

grr… ok that means we need to comment out that task in the ansible playbook. I will also open an issue for that, if the files exist RockNSM shouldn’t be modifying them.

edit /usr/share/rock/roles/common/tasks/configure.yml

Comment out lines 194 - 206


#36

It says it installed correctly but now there is this issue:

Apparently none of the services installed?

*** Note the Config.yml is the default one with everything set to true


#37

Can you provide the output of
sudo yum repolist


#38


#39

you may need to clean the repo’s. Looks like they are still messed up.
24%20PM

Try cleaning the repo’s
sudo yum clean all
sudo makecache fast

Then try to manually install something to see if its working
sudo yum install zookeeper


#41

@spartan782 I was able to install zookeeper manually


#42

The Screenshot is after I manually installed Zookeeper and Bro. It says they are disabled in systemctl but enabled by rock. Also at the bottom when I do ls /data there is nothing there.