Deployment error


Greetings from a noob.
I downloaded the iso file yesterday and attempted to install it as a VM (2 cores 4GbB ram, 20GB HD)
created the admin use just like in the YouTube video, did the update and rebooted. I didn’t edit the config file and did run the sudo /opt/rocknsm/rock/bin/ command. When I try to run the deploy command I get an error at the Task [Render Template] I’m writing this from work not my home lab so I don’t have the exact message available at the moment. I was wondering if anyone else got this?



If I had to take a stab at it without seeing the logs, I would the second NIC may not be there “physically” or properly identified in the config file. Only because I forget to do it ALL the time.

By the way, looking at your VM specs i don’t think you will have enough ram and cores to run all the things. If your not collecting a lot of stuff then the harddrive should be enough.

If you get a copy of the error by running the deploy script again and paste it here we can start to chase it down.



Got a little further, decided to go straight onto an ESXi host. installed with 1 error

not sure what this means. I can’t access the http portal


Tried again, and still no luck. Can anyone help?


@mblanke looks like you need to run the deploy script with sudo. The specific error you’re getting is:

sudo: a password is required

Under the hood Ansible is invoking sudo, but your account requires a password to elevate privileges. Running the following should fix it by elevating the script to root before Ansible runs (once you enter your admin password)

sudo /opt/rocknsm/rock/bin/


I’ve run it with
sudo /opt/rocknsm/rock/bin/
DEBUG=1 ./ | tee /tmp/deploy_rock.log

still get an error when deploying. can’t tell if it is the same error mind you.


can you set the option for “rock_online_install:” to “True” in /etc/rocknsm/config.yml

let me know if that fixes your error and or if you have any other questions