Add inventory to /etc/host

#1

I get an error when running the deploy.sh script. Screenshots of the error are below.

The file mentioned:

Any ideas on whats causing this? I’m using the ISO and have
rock_online_install: False

I commented out lines 72-80 and it seems to have passed by the error and is now installing the core packages. Any idea what this section does/adds and will it effect Rock’s usage?

0 Likes

#2

you need to add the hosts.ini file to /etc/hosts. So…

sudo vi /etc/hosts.ini

Paste the following into the file. It should also be available in etc/host.ini in a clone of the rock git repo. This file basically tells ansible where to deploy everything. This is especially important to a multi-node deployment.

[rock]
simplerockbuild.simplerock.lan ansible_host=127.0.0.1 ansible_connection=local

[web]
simplerockbuild.simplerock.lan ansible_host=127.0.0.1 ansible_connection=local

[sensors:children]
rock

[bro:children]
sensors

[fsf:children]
sensors

[kafka:children]
sensors

[stenographer:children]
sensors

[suricata:children]
sensors

[zookeeper]
simplerockbuild.simplerock.lan ansible_host=127.0.0.1 ansible_connection=local

[elasticsearch:children]
es_masters
es_data
es_ingest

[es_masters]
# This group should only ever contain exactly 1 or 3 nodes!
simplerockbuild.simplerock.lan ansible_host=127.0.0.1 ansible_connection=local
# Multi-node example #
#elasticsearch0[1:3].simplerock.lan

[es_data]
simplerockbuild.simplerock.lan ansible_host=127.0.0.1 ansible_connection=local
# Multi-node example #
#elasticsearch0[1:4].simplerock.lan

[es_ingest]
simplerockbuild.simplerock.lan ansible_host=127.0.0.1 ansible_connection=local
# Multi-node example #
#elasticsearch0[1:4].simplerock.lan

[elasticsearch:vars]
# Disable all node roles by default
node_master=false
node_data=false
node_ingest=false

[es_masters:vars]
node_master=true

[es_data:vars]
node_data=true

[es_ingest:vars]
node_ingest=true

[docket:children]
web

[kibana:children]
web

[logstash:children]
sensors
0 Likes

#3

Sorry, I meant to update this a few days ago. Apparently the issue was related to not having an IP on my management interface. Thanks for helping.

0 Likes